CCNA LAB - 2.1 InterVLAN Routing


                                                                       Download

LAB 2-1: InterVLAN Routing 

You are the Network Administrator at Ranet, and have to config both switch "Ranet-SW" and router 
"Ranet-GW" via its console terminal as below: 


    1. Set Ranet-SW to seperate VLAN to be VLAN 10 and VLAN 20 and set its member as: 
          VLAN 10: Fa0/1, Fa0/2 
          VLAN 20: Fa0/3, Fa0/4 

    2. Enable feature "Portfast" on all access ports. 

    3. Set both Ranet-SW and Ranet-GW to route between VLAN 10 and VLAN 20: 

          - Use interface Fa0/0.1 and Fa0/0.2 on Ranet-GW as sub-interface for VLAN 10 and 
            VLAN 20 respectively.
          - Please note that all hosts in each VLAN set IP Default Gateway to be the last IP of its 
            own subnet. 

If everything is correct, All hosts will be able to connect with each other.


--------------  End -------------------

Solution

Ranet SW config

Ranet-SW>en
Ranet-SW#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Ranet-SW(config)#vlan 10
Ranet-SW(config-vlan)#vlan 20
Ranet-SW(config-vlan)#int ran fa0/1 -2
Ranet-SW(config-if-range)#switchport mode access
Ranet-SW(config-if-range)#switchport access vlan 10
Ranet-SW(config-if-range)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc... to this
interface when portfast is enabled, can cause temporary bridging loops.
Use with CAUTION
%Portfast will be configured in 2 interfaces due to the range command
but will only have effect when the interfaces are in a non-trunking mode.
Ranet-SW(config-if-range)#int ran fa0/3 -4
Ranet-SW(config-if-range)#switchport mode access
Ranet-SW(config-if-range)#switchport access vlan 20
Ranet-SW(config-if-range)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc... to this
interface when portfast is enabled, can cause temporary bridging loops.
Use with CAUTION
%Portfast will be configured in 2 interfaces due to the range command
but will only have effect when the interfaces are in a non-trunking mode.
Ranet-SW(config-if-range)#int gig1/1 2
Ranet-SW(config-if)#switchport mode trunk
Ranet-SW(config-if)#
%SYS-5-CONFIG_I: Configured from console by console
Ranet-SW#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
Ranet-SW#

Ranet GW config

Ranet-GW>en
Ranet-GW#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Ranet-GW(config)#int fa0/0
Ranet-GW(config-if)#no sh
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Ranet-GW(config-if)#int fa0/0.1
Ranet-GW(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.1, changed state to up
Ranet-GW(config-subif)#encapsulation dot1Q 10
Ranet-GW(config-subif)#ip add 192.168.0.142 255.255.255.240
Ranet-GW(config-subif)#int fa0/0.2
%LINK-5-CHANGED: Interface FastEthernet0/0.2, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.2, changed state to up
Ranet-GW(config-subif)#encapsulation dot1Q 20
Ranet-GW(config-subif)#ip add 192.168.0.158 255.255.255.240
Ranet-GW(config-subif)#
%SYS-5-CONFIG_I: Configured from console by consoleRanet-GW#
Ranet-GW#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
192.168.0.0/28 is subnetted, 2 subnets
C 192.168.0.128 is directly connected, FastEthernet0/0.1
C 192.168.0.144 is directly connected, FastEthernet0/0.2

Ranet-GW#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
Ranet-GW#

------------------- End --------------------

Now, all host will be able to connect with each other.

You can download this solution here.






  1. Cảm ơn anh nhiều.Có bài nào mới send mail cho em vs nha anh.Mail của em đây.hoanggia213@gmail.com

Leave a Reply

Các bạn có thể viết lời nhận xét cho bài viết, nhưng cần tuân thủ một số quy tắc sau:

» Các bài comment phải nghiêm túc, không dung tục, không spam.
» Nội dung phải liên quan tới chủ đề bài viết.
» Viết bằng tiếng việt có dấu hoặc tiếng Anh. Các comment viết không dấu sẽ bị xóa.
» Hãy để lại tên của bạn khi comment, để tôi có thể dễ dàng trả lời comment của bạn khi cần.

Xin cảm ơn & chúc các bạn tìm được những kiến thức bổ ích khi tình cờ ghé thăm blog này.