MIKROTIK REALTIME TRAFFIC MONITORING

GIÁM SÁT BĂNG THÔNG TRÊN ROUTER MIKROTIK

Tôi thường triển khai hệ thống wifi bằng router Mikrotik cho các quán cafe vì độ ổn định, giá tốt và hiệu quả. Vì có nhiều anh em hỏi cách theo dõi băng thông trên Mikrotik để...chống trộm ^^!

Nay tôi viết hướng dẫn nho nhỏ này để giải đáp thắc mắc. :)







1/ Cấu hình các thông số trên router Mikrotik cho phép gửi traffic:


/user
group add name=sniffer policy="ssh,read"
add address=172.16.1.0/24 disabled=no group=sniffer name=sniffer




 /ip accounting
 set account-local-traffic=no enabled=yes threshold=2560



 /ip accounting web-access
 set accessible-via-web=yes address=172.16.1.XXX/32    

(XXX  là IP của máy Windows machine sẽ chạy tool theo dõi)

Khuyến cáo là gán static IP cho PC đó luôn.

/ip dhcp-server lease
add address=172.16.1.200 client-id=1:60:67:20:77:80:1A mac-address=60:67:20:77:80:1A comment=" VNSYSADMIN-SERVER" server=dhcp1

Xem thử traffic dạng txt:  http://<router_ip>/accounting/ip.cgi


2/ Các bạn  download đồ chơi :

http://files.vnsysadmin.com/Mikrotik/tools/SnifferService.zip
http://files.vnsysadmin.com/Mikrotik/tools/SnifferViewer.zip


3/ Cài đặt dịch vụ Monitoring
--------------------------
-  Giải nén "SnifferService.zip"  và chép vào C:\Program Files (x86)\Sniffer
-  Khai báo thông số Router vào file:  snifferservice.ini
- Mở CMD (run as Administrator), gõ vào:   SnifferService.exe /install
- Start service "Sniffer" trong  Services Manager.
- Kiểm tra snifferservice.log để chắc chắn rằng dịch vụ chạy OK! Mặc định nó chạy port 80.

Kiểm tra thử:
- Từ một PC khác,thử truy cập vào http://172.16.1.200 sẽ thấy traffic text
- Truy cập http://172.16.1.200/ip sẽ thấy IP text


4/ Cấu hình dịch vụ Viewer
-------------------------
- Giải nén SnifferViewer.zip  trên một thư mục nào đó
- Khai báo các thông số router vào sniffer.ini để get thông tin
- Chạy SnifferViewer.exe

5/ Nhâm nhi ly cafe và bóp cổ đứa nào xài nhiều quá ^^!

http://blog.vnsysadmin.com/2017/04/mikrotik-realtime-traffic-monitoring.html

Leave a comment

0 Comments.

Leave a Reply

Các bạn có thể viết lời nhận xét cho bài viết, nhưng cần tuân thủ một số quy tắc sau:

» Các bài comment phải nghiêm túc, không dung tục, không spam.
» Nội dung phải liên quan tới chủ đề bài viết.
» Viết bằng tiếng việt có dấu hoặc tiếng Anh. Các comment viết không dấu sẽ bị xóa.
» Hãy để lại tên của bạn khi comment, để tôi có thể dễ dàng trả lời comment của bạn khi cần.

Xin cảm ơn & chúc các bạn tìm được những kiến thức bổ ích khi tình cờ ghé thăm blog này.