Cisco Discovery Protocol (CDP)

Hôm nay lại viết tiếp những bài lab còn giang giở … Cách cấu hình phần mềm để có thể làm lab thì đã được anh Cường giới thiệu cho chúng ta rồi. Ở đây tôi xin nói thêm một chút về GNS3 theo tôi đây là phần mềm mô phỏng hệ thống lab của CISCO tối ưu nhất, trước đây mới chỉ dùng Dynamips, Dynagen với phần thiết kế thì bạn tự làm ra giấy phần mô hình mạng rồi kết nối các thiết bị tự mình tưởng tượng lên. Nhưng với GNS3 thì đã có phần cho phép bạn thiết kế mô hình mạng trực quan. Sử dụng IOS gốc của CISCO nên tất cả các lệnh trong lab thật hầu như có hết trong GNS3. Tôi khuyên các bạn nên dùng GNS3 để mô phỏng và thực hành.
Một số câu lệnh cơ bản cũng đã được tôi giới thiệu ở bài 3. Hôm nay chúng ta bước sang bài tiếp theo là CDP.

Highslide JS
Mô tả
Cisco Dicovery Protocol là một giao thức dùng cho đồ của Cisco. Là một giao thức lớp 2 (Data Link Layer) cho phép ta thu nhập thông tin về thiết bị lân cận. Như
  Hostname
  Address list
  Port ID
  Platform
Các thông tin này rất hưu ích khi xử lý sự cố hoặc kiểm soát thiết bị trong hệ thống mạng
Hôm nay bài thực hành được mô phỏng như hình trên
Thực hiện
Trước tiên, cấu hình các router như sau. Mặc định, các thiết bị Cisco đã có cho phép giao thức CDP. Do đó, khi dùng lệnh show run, thông tin về CDP sẽ không được hiển thị.
RouterA
!
hostname RouterA
!
interface serial0
ip address 172.16.10.1 255.255.255.0
clock rate 64000 ← hoạt động như là DCE cung cấp xung clock
no shut
!
interface ethernet0
ip address 192.168.0.1 255.255.255.0
no shut
!
no ip classless
!
line console 0
line aux 0
line vty 0 4
login
!
end

RouterB
!
hostname RouterB
!
interface serial0
ip address 172.16.10.2 255.255.255.0
no shut
!
no ip classless
!
line console 0
line aux 0
line vty 0 4
login
!
End
1.Để xem thông tin về các thông số thời gian của CDP, dùng lệnh show cdp (hay sh cdp)
Router#sh cdp
Global CDP information:
Sending CDP packets every 60 seconds
Sending a holdtime value of 180 seconds
Router#
Dùng lệnh cdp holdtime và cdp timer để đặt lại thời gian gởi và thời gian giữ gói cho router.
– CDP timer là chu kỳ gởi gói CDP tới tới tất cả cổng đang hoạt động.
– CDP holdtime là khoảng thời gian thiết bị giữ gói nhận được từ láng giềng.

RouterA#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#cdp ?
holdtime Specify the holdtime (in sec) to be sent in packets
timer Specify the rate at which CDP packets aresent(in sec)
run
RouterA(config)#cdp timer 90
RouterA(config)#cdp holdtime 240
RouterA(config)#^Z
 Kí hiệu này nghĩa là bạn nhấn Ctrl+Z thay cho lệnh exit

Bạn có thể tắt hòan tòan giao thức CDP trong thiết bị Cisco với lệnh no cdp run. Để tắt CDP trên một cổng sử dụng câu lệnh no cdp enable trên cổng đó.

2.Lệnh show cdp neighbor (viết tắt sh cdp nei) hiện thông tin về thiết bị nối trực tiếp.

RouterA#sh cdp nei
Capability Codes: R - Router, T - Trans Bridge,
B - Source Route Bridge, S - Switch, H - Host,
I - IGMP, r - Repeater
Device ID Local Interfce Holdtme Capability Platform Port ID
Switch Eth 0 238 T S 1900 2
RouterB Ser 0 138 R 2500 Ser 0
RouterA#
Một lệnh khác cho biết thông tin về các thiết bị láng giềng là show cdp neighbor detail (show cdp nei de), cũng có thể chạy trên router và switch

RouterA#sh cdp neighbor detail
-------------------------
Device ID: 1900Switch
Entry address(es):
IP address: 0.0.0.0
Platform: cisco 1900, Capabilities: Trans-Bridge Switch
Interface: Ethernet0, Port ID (outgoing port): 2
Holdtime : 166 sec
Version :
V9.00
-------------------------
Device ID: 2501B
Entry address(es):
IP address: 172.16.10.2
Platform: cisco 2500, Capabilities: Router
Interface: Serial0, Port ID (outgoing port): Serial0
Holdtime : 154 sec
<...>
RouterA#

Ngoài ra, lệnh show cdp entry * cũng hiển thị thông tin tương tư.̣
Lệnh show cdp traffic hiển thị lưu lượng tại cổng gồm cả số gói CDP gởi nhận và bị lỗi :

RouterA#sh cdp traffic
CDP counters:
Packets output: 13, Input: 8
Hdr syntax: 0, Chksum error: 0, Encaps failed: 0
No memory: 0, Invalid packet: 0, Fragmented: 0
RouterA#

3.Thông tin trạng thái CDP trên port hay cổng hiển thị bằng lệnh show cdp interface (sh cdp int)
Như đã đề cập trước, có thể tắt CDP hoàn toàn trên router dùng lệnh no cdp run. Tuy nhiên, muốn tắt CDP trên từng cổng dùng lệnh no cdp enable. Có thể cho phép CDP trên một port bằng lệnh cdp enable.
Trên router, show cdp interface cho thông tin về từng cổng dùng CDP, gồm cả dạng đóng gói trên đường truyền, timer và holdtime trên mỗi cổng

RouterA#sh cdp interface
Ethernet0 is up, line protocol is up
Encapsulation ARPA
Sending CDP packets every 60 seconds
Holdtime is 180 seconds
Serial0 is administratively down, line protocol is down
Encapsulation HDLC
Sending CDP packets every 60 seconds
Holdtime is 180 seconds
Serial1 is administratively down, line protocol is down
Encapsulation HDLC
Sending CDP packets every 60 seconds
Holdtime is 180 seconds
Tắt CDP trên một cổng

RouterA#config t
Enter configuration commands, one per line. End withCNTL/Z.
RouterA(config)#int s0
RouterA(config-if)#no cdp enable
RouterA(config-if)#^Z

Kiểm tra lại sự thay đổi đó.

RouterA#sh cdp int
Ethernet0 is up, line protocol is up
Encapsulation ARPA
Sending CDP packets every 60 seconds
Holdtime is 180 seconds
Serial1 is administratively down, line protocol is down
Encapsulation HDLC
Sending CDP packets every 60 seconds
Holdtime is 180 seconds
Router#

Bài viết trên có tham khảo của vnpro. Tôi đã có chỉnh sửa thêm chút ít để các bạn dễ hiểu hơn


                                                                                                                        Write by ledem64

Leave a Reply

Các bạn có thể viết lời nhận xét cho bài viết, nhưng cần tuân thủ một số quy tắc sau:

» Các bài comment phải nghiêm túc, không dung tục, không spam.
» Nội dung phải liên quan tới chủ đề bài viết.
» Viết bằng tiếng việt có dấu hoặc tiếng Anh. Các comment viết không dấu sẽ bị xóa.
» Hãy để lại tên của bạn khi comment, để tôi có thể dễ dàng trả lời comment của bạn khi cần.

Xin cảm ơn & chúc các bạn tìm được những kiến thức bổ ích khi tình cờ ghé thăm blog này.